Электротранспорт

Пожалуйста, войдите или зарегистрируйтесь.

Расширенный поиск    

Новости:

Страницы: 1Вниз

Автор Тема: ARDUINO- проблема с версией  (Прочитано 799 раз)

0 Пользователи и 1 Гость просматривают эту тему.

Installer PRO

  • Старожил
  • *****
  • Репутация:
    +28/-0
  • :
  • Сообщений: 1051
  • Москва
  • Жизнь идет, и я меняюсь...
  • Оффлайн Оффлайн
    • Награды
ARDUINO- проблема с версией
« : 15 Фев 2016 в 17:05 »
У меня появилась проблема – есть старая версия программы- Arduino 1.0.5-r2.
При компилировании скетча с применением библиотек OneWire и  DallaceTemperature появляется сообщение, что недостаточно памяти для обработки программы.
Я скачал и установил новую версию с сайта https://www.arduino.cc/en/Main/Software  - Arduino 1.6.7
Но в ней не увидел своей платы. В сети нашел описание, как изменить файл boards.txt. Изменил. Плату как бы видно, но при загрузке появляется сообщение - ошибка при загрузке - пропущен параметр конфигурации upload.tool
Вопрос к знатокам- как из старой версии ПО вынуть данные по примененной плате и закачать в новую версию, чтобы все работало?


zanuda

  • Неравнодушный
  • **
  • Репутация:
    +5/-0
  • :
  • Сообщений: 118
  • Россия, Санкт-Петербург
  • А самокат с моторчегом
  • Оффлайн Оффлайн
    • Награды
ARDUINO- проблема с версией
« Ответ #1 : 15 Фев 2016 в 21:28 »
А какая доска используется? И почему думаете что в новой версии вам памяти хватит?

Installer PRO

  • Старожил
  • *****
  • Репутация:
    +28/-0
  • :
  • Сообщений: 1051
  • Москва
  • Жизнь идет, и я меняюсь...
  • Оффлайн Оффлайн
    • Награды
ARDUINO- проблема с версией
« Ответ #2 : 16 Фев 2016 в 01:05 »
А какая доска используется? И почему думаете что в новой версии вам памяти хватит?
Arduino Uno 3.0.  На плате стоит ATMEGA8A-PU  Что не так?

Страницы: 1Вверх
 

Размер занимаемой памяти: 4 мегабайта.
Страница сгенерирована за 0.956 секунд. Запросов: 39.