Электротранспорт
Пожалуйста, войдите или зарегистрируйтесь.


Расширенный поиск    

Реклама:

Скосило и размолотило плату с датчиками холла внутри МК +фото

Страницы: 1Вниз

Автор Тема: Скосило и размолотило плату с датчиками холла внутри МК +фото  (Прочитано 689 раз)

0 Пользователи и 1 Гость просматривают эту тему.

electrobiker

  • Старожил
  • *****
  • Репутация: 82
  • Сообщений: 1388
  • Москва
  • Оффлайн Оффлайн
    • Награды
Вот снова приходится обращаться за советом, друзья.

Проблема с работой редукторного МК 8FUN SWX02 48V.

А именно, каким-то образом чудесным образом скосило плату датчиков холла, скорее всего по причине того, что я не приклеил её при прошлом ремонте, но это уже не важно.
Факт есть в том, что плату разломило на три части и восстановлению она не подлежит.

Благо обмотки не пострадали, фазовые провода в порядке, но когда косило все сигнальные провода то коротнуло и в местах датчиков холла на плате хорошо видны следы этого короткого замыкания.

Схему распайки я составил на бумаге, проверил её раз тридцать, реанимировал провода и  поставил на места новые датчики холла. Колесо поехало, но если с нуля со старта давать газу, то мотор издаёт характерный такой звук типа «трык-трык», уменьшилась максимальная скорость и, поскольку я выяснил проблему связанную с датчиками холла, могу сделать вывод, что это режим работы без датчиков.

Сложности возникают именно при старте с нуля, так если велосипед уже движется и газ не скидываешь, а малым-мало поддаёшь, то едет всё хорошо, но вместо 35км/ч где-то 29км/ч, как газ скинешь до нуля и в какой-нибудь грязи стартанёшь, то мотор может вместо желаемой тяги дать этот самый «трык-трык» и предательски подвести. Со мной это уже неоднократно случилось в самых неподходящих местах, езжу по лесам, где много грязи и местами топь, в Лосином Острове например.

Проблема в том, видно, что если подключить всё согласно имеющейся распайке, то при движении магнитов нет совершенно никаких изменений с сигнальной ноги, там постоянно 2.7v, а на + и -  4.4v, всё в норме по даташиту, однако ничего… Когда провод с ноги отпаиваешь, то видно, что датчик работает, данные, при смещении магнитов, меняются.

У меня было предположение, что это может быть связано с тем, что я исключил из схемы конденсаторы «C», это SMD конденсаторы совершенно микроскопические, я использовал один из них для включения в схему и напаял его на один из датчиков холла, а так же после пробовал использовать 104 конденсатор, но результата это не дало, опять на ноге висит постоянное напряжение.

У меня лично в голове вопрос номер 1) Могло ли при замыкании + и — внутри МК на ногах датчика холла, привести к выходу из строя какой-то части контроллера и может ли это влиять на то, что при подпаяной сигнальной ноге эта поломка мешает работать датчику холла и менять на себе напряжение?

Коллеги, помогите пожалуйста советом или мыслью какой.

илс

  • Глобальный модератор
  • Старожил
  • **
  • Репутация: 351
  • Сообщений: 25858
  • Москва, Крылатское
  • Оффлайн Оффлайн
    • Награды
, может даже и хорошо, что плату снесло.
Ибо мне это пришлось делать вручную, потратил кучу времени и сил.
На фото мотор МАС, но принцип одинаковый, сперва используется фреза дремеля, а потом термофен:
Скрытый текст

Менял холлы по просьбе форумчанина, без платы это делается легко и просто.
А из-за платы, пришлось провода удлинять, получилось немного колхозно...
Скрытый текст

Если (ваши) холлы работают некорректно, то видимо  их надо распаять так, чтобы работали, корректно. Или заменить, на новые  :-)
Если вдруг не разберетесь, привозите в Крылатское, отремонтирую, за недорого...
==========
Замыкание ножек ДХ не должно палить контроллер, там стоит защита.
Но если коротить долго, может и сгореть стабилизатор на +5В.  :bn:
Но ведь это просто проверить. Надо рассказывать, как именно?  :ah:

Филя

  • Неравнодушный
  • **
  • Репутация: 2
  • Сообщений: 242
  • Украина, Харьков
  • Segway-club
  • Оффлайн Оффлайн
    • Награды
Проблема в том, видно, что если подключить всё согласно имеющейся распайке, то при движении магнитов нет совершенно никаких изменений с сигнальной ноги, там постоянно 2.7v, а на + и -  4.4v, всё в норме по даташиту, однако ничего… Когда провод с ноги отпаиваешь, то видно, что датчик работает, данные, при смещении магнитов, меняются.


Как я понял,  на трех входах для датчиков холла (на контроллере) присутствует напряжение 2,7В ?
Если так , то его не должно там быть.
4,4В Это питание датчиков.

electrobiker

  • Старожил
  • *****
  • Репутация: 82
  • Сообщений: 1388
  • Москва
  • Оффлайн Оффлайн
    • Награды
Моё глубокое почтение отозвавшимся!  :hello:

илс: моё особенное Вам с кисточкой, я уже с этой проблемой полгода борюсь :) поэтому ради решения вопроса поеду хоть в Лобню или Зеленоград :) С радостью принимаю предложение помощи, за мной, разумеется не заржавеет. Однако я хочу уточнить ситуацию, ибо у меня уже ум за разум зашёл...  /:-)
Совершенно согласен, что можно обойтись и без платы, её легко имитировать проводами, что я и сделал. Плату изучал с зимы, как поломка случилась я так и пытаюсь понять в чём дело. Даю дополнительную картинку о ситуации. Возможно датчики холла действительно накернились, их есть у меня, странно, что они прикидываются рабочими при отпаянной сигнальной ноге...

Филя: специально всё измерил заново и как-то всё стало совсем непонятно, раньше где-то было 2.75в теперь их нигде нет, а есть 3.3в на сигнальных ногах при отпаянном проводе и данные меняются, а при припаянном сигнальном проводе по -0.69в...

H - сигнальная нога



AutoLand

  • Старожил
  • *****
  • Репутация: 12
  • Сообщений: 2917
  • Россия, Москва, фили
  • Тел: 8(915)302-78-б5, Тимур!
  • Оффлайн Оффлайн
    • Награды
О раз я сюда зашел. Подскажите. У клиента на велике стоит контролер который умеет и без холлов работать и аот иногда этот режим врубается сам по снбе похоже. А иногда все ок но в последнее время часто врубается. Надо бы контакты проверить в разъеме еще.. но с начало он ездил ок. Потом почему то начал то бездатчиковый режим включать то все норм. Чет походу сам себе на вопрос ответил про разъем

Филя

  • Неравнодушный
  • **
  • Репутация: 2
  • Сообщений: 242
  • Украина, Харьков
  • Segway-club
  • Оффлайн Оффлайн
    • Награды
...специально всё измерил заново и как-то всё стало совсем непонятно...

 Мне тоже непонятно. :laugh:
Особенно -0.69В 
А почему относительно плюса вы напряжение измеряли? Надо относительно минуса (общего провода).

На фото у вас напряжение измеренно с  подключенным сигнальным проводом?
А как так получилось, что при питании на датчике холла в 4,20В на его выходе 4.89В?   %-)

илс

  • Глобальный модератор
  • Старожил
  • **
  • Репутация: 351
  • Сообщений: 25858
  • Москва, Крылатское
  • Оффлайн Оффлайн
    • Награды
Дистанционная диагностика полупроводников требует незаурядных  телепатических способностей.
Лично я,  мало что понял, из прочитанного выше.  :kidding:

У ДХ Холла три вывода, это минус или земля, +5В и сигнальный. Соответственно сперва убеждаемся что на всех трех ДХ есть честные +5В (или +4,5, это неважно)
Дальше все просто, относительно минуса меряем напругу на сигнальном, медленно вращая колесо.
Редукторник разумеется вращаем в противоположную, от направления вращения,  - сторону.  ;-)

На сигнальном наблюдаем регулярные скачки (прыжки)  напряжения.
ВСЁ, тест закончен :eureka:

Страницы: 1Вверх
 

Помощь форуму | Отказ от ответственности | Новая версия форума
©, Форум электротранспорта, electrotransport.ru, 2007—2018.
Копирование материалов возможно только с согласия правообладателя.

Размер занимаемой памяти: 5.5 мегабайт.
Страница сгенерирована за 0.145 секунд. Запросов: 66.

Powered by SMFPacks Alerts Pro Mod
Powered by SMFPacks Mentions Pro Mod