Kugoo S3 не реагирует на газ и тормоз

Автор Alexey1504, 02 Авг. 2021 в 14:35

« назад - далее »

0 Пользователи и 1 гость просматривают эту тему.

Alexey1504

Доброго дня!

Включается, никаких ошибок на экране. Если выдернешь штекер из МК, показывает ошибку.
Не реагирует на газ и тормоз. Совсем. Но индикация на дисплее при нажатии на курок тормоза работает.

Контроллер МК разобрал: мосфеты целые, резистор 100 ОМ целый, визуально всё хорошо.
Все контакты позвонил, всё везде проходит. Разве что МК не разбирал. Но вроде, как понимаю, если в МК обрыв, должен индицировать ошибку.

Почитал по форумам, что сигналы Rx Tx надо смотреть при нажатии на курки, но проблема в отсутствии осциллографа. Мерял мультиметром, на шинах по несколько вольт стоит, при нажатии на курки напряжение не меняется совсем.

И вот ещё какой нюанс, предполагаю, что важный: когда включенный ведешь со скоростью 2-3 км/час, на дисплее скорость завышена - больше 10 км/ч отображает.

Это по сути мой первый самокат в ремонте, вообще по умолчанию ноутбуко-, компьютеро-, телемастер. Так что сильно не ругайте, пока ещё только обрывочные сведения по ним имею.

кот ленивый

Искусственный интеллект нужен тем, у кого нет своего.

Alexey1504

Цитата: кот ленивый от 02 Авг. 2021 в 15:45
Зеро старт отключил? :-)

Пробовал, не помогает)

Да, ещё вот что: проверил на клемме выходы с МК: всё как положено - 4,3 В, а на трёх выходах с датчиков - от 0 до 3,3В при кручении колеса.

Sonar

Цитата: Alexey1504 от 02 Авг. 2021 в 14:35ноутбуко-, компьютеро-, телемастер
и без осциллографа? Такое разве бывает? :)

Какие контроллеры у вас стоят на самокате (фотки плат очень желательны)? Версий контроллеров много разных и каждый работает по своему.
Стоп-сигнал (задний) загорается при нажатии на курок тормоза?
Kugoo S2 blue, 36v 20,8A/h, 2x600W, Prog disp v3.8, Prog drive v1.9 odo: 26705km.
Все материалы по альтернативным контроллерам для Kugoo S2: http://213.21.12.200/kugoo_project/
Тема на форуме по этим контроллерам https://electrotransport.ru/index.php?topic=61126.0

Alexey1504

Цитата: Sonar от 02 Авг. 2021 в 16:13ноутбуко-, компьютеро-, телемастер
и без осциллографа? Такое разве бывает?

Бывает) Старый забыл по прежнему месту жительства. А новый ещё не успел заказать) А так, осциллограф на самом деле крайне редко нужен для ремонта этих устройств.

Задний стоп-сигнал, как я понял, отрезан. Клемма висит в воздухе, ответной клеммы не нашел.

Как тут картинки вставить, я не знаю.)

Intelligent Brushless
36 V 350 W
Under Voltage 29V Current: 14A

Jinhua Huihao Technology Co Ltd

Если это хоть как то прояснит ситуацию)

6 мосфетов внутри


Sonar

Kugoo S2 blue, 36v 20,8A/h, 2x600W, Prog disp v3.8, Prog drive v1.9 odo: 26705km.
Все материалы по альтернативным контроллерам для Kugoo S2: http://213.21.12.200/kugoo_project/
Тема на форуме по этим контроллерам https://electrotransport.ru/index.php?topic=61126.0

Alexey1504

Получается модель S3
Контроллер PJXLB1.2

Sonar

[user]Alexey1504[/user], сигналы, идущие по TX/RX можно проверить с помощью USB-UART переходника. Заодно и понять, меняются ли значения байт при нажатии на курок газа или тормоза.
Kugoo S2 blue, 36v 20,8A/h, 2x600W, Prog disp v3.8, Prog drive v1.9 odo: 26705km.
Все материалы по альтернативным контроллерам для Kugoo S2: http://213.21.12.200/kugoo_project/
Тема на форуме по этим контроллерам https://electrotransport.ru/index.php?topic=61126.0

Alexey1504

Уфф... взял программатор CH341a, перевел в режим UART.

Теперь консультируйте, всё ли верно делаю: ))
Подцепил Rx программера на Tx контроллера, соответствено Tx на Rx, землю на землю.

Программатор встал COM3 порт, выставил ему скорость 115200

Запустил Terminal v1.9, выcтавил COM3 и скорость 115200, Data bits - 8, Parity - none, stop bits - 1, handshaking - none.

Запускаю коннект, включаю самокат - начинают бежать 00 00 00 00....

Нажимаю курки, ничего не меняется - одни сплошные нули.

Oszau

Скорость 9600. После подачи питания на контроллер соединить красный с синим. Не ленимся после отключения контроллера(для манипуляций с ним) снять статику с кондеров сопротивлением 10к на 5ват. А то я так пару тройку процев спалил уже.

Alexey1504

Цитата: Oszau от 03 Авг. 2021 в 11:57После подачи питания на контроллер соединить красный с синим.

А бабаха не случится точно?)) За что эти провода отвечают?

Sonar

[user]Alexey1504[/user], бабаха быть не должно. Красный провод подключен напрямую к + батареи. По синему проводу идет батарейное питание в контроллер мотор-колеса для питания его логической части и драйверов транзисторов.
Kugoo S2 blue, 36v 20,8A/h, 2x600W, Prog disp v3.8, Prog drive v1.9 odo: 26705km.
Все материалы по альтернативным контроллерам для Kugoo S2: http://213.21.12.200/kugoo_project/
Тема на форуме по этим контроллерам https://electrotransport.ru/index.php?topic=61126.0

Alexey1504

Всё сделал как сказали. Бегут нули, одни нули... Никакой реакции на курки. Да, ещё проверил подается ли напряжение на стоп-сигнал при нажатии курка тормоза. Ничего не подаётся.

Я правильно понимаю, что нужно менять плату верхнего контроллера, или как там её правильно обозвать)?

Sonar

[user]Alexey1504[/user], отключите TX платы контроллера дисплея от RX платы контроллера мотор-колеса и подключитесь USB-UART переходником к TX платы контроллера дисплея. Если всё равно будут нули - тогда либо смотреть резистор на плате дисплея в цепи шины TX, либо менять дисплей.
На моей памяти у этого комплекта контроллеров встречался подгоревший RX на контроллере мотор-колеса.
Kugoo S2 blue, 36v 20,8A/h, 2x600W, Prog disp v3.8, Prog drive v1.9 odo: 26705km.
Все материалы по альтернативным контроллерам для Kugoo S2: http://213.21.12.200/kugoo_project/
Тема на форуме по этим контроллерам https://electrotransport.ru/index.php?topic=61126.0

Alexey1504

Нашел горелый резистор 100 Ом на плате дисплея, уже обрадовался, что нашёл неисправность. Перепаял, включил - ничего...((

Всё остальное пересмотрел, ножки микросхемы паяльником прошёл на всякий случай - не помогло.

Oszau

Я бы начал с контроллера, чтобы определить версию протокола. Отключил бы полностью от всего контроллер, подключил бы только аккумулятор(я подключаю лабораторник 30в и 200-300ма чтобы не сгорела хата)  к нему, черный и зеленый провод на RX компа и замкнул красный с синим. Если пошли фреймы протокола, то дальше отдельно дисплей по такому принципу. Только потом их соединял бы вместе.

Argon1024

Если ошибку МК показывает, значит связь односторонняя есть. (с низу вверх). У меня выгорал входной резистор 100 Ом на плате МК, после того, как я на его RX подал 40в (случайно). При этом визуально на резисторе (0603) в центре видно тепловой перегрев в виде кругленького пузырика.
Kugoo S3 GT

Aleks13

#17

Парни, нид хэлп! Ситуация следующая, есть зверь, S3 pro jilong начал показывать 04 вместо скорости, при этом колесо крутил, тормозил, но плохо, через раз. Вскрытие показало, что отломались провода желтый зеленый шины от БК, от платы внутри контроллера МК. Подпаял их обратно, ошибка 04 исчезла, но поведение самоката точно как в первом посте, т.е. на гашетки не реагирует, колесо не крутит, габариты и стоп не светит. Скорость показывает при прокручивании, если отсоединить разьем МК, то показывает ошибку, колесо от руки крутится легко. Что могло навернуться непонятно :( Проц STM8S103 контроллер МК PJXLB1.2

зы не могу прикрутить картинки, в профиле есть
плата БК https://electrotransport.ru/images/4/1m5m9kg.jpeg
верхняя панель https://electrotransport.ru/images/4/1i6j8sp.jpeg
название модели на рулевой https://electrotransport.ru/images/4/12arsyp.jpeg
плата МК https://electrotransport.ru/images/4/1d1o1us.jpeg